This topsOrtho™ Workstation
Needs more RAM to Upgrade

This topsOrtho™ workstation needs a minimum of 8GB of RAM to upgrade to macOS Catalina (OS 10.15.x).

macOS Catalina is the most secure version of macOS to date.

Keeping your OS up-to-date keeps you safe from ransomware and allows you to run the latest version of topsOrtho™.

Contact our Hardware Specialist—Kalin—at topstotalpackage@topsOrtho.com to discuss your options.

 

Never upgrade the topsServer without contacting us first!

As with any Software upgrade, please verify your external devices (printers, scanners, Xray equipment, etc.) and other software are compatible prior to installing the upgrade.

Check the p1nk page on each of your practice workstations to see which are ready for upgrade to macOS Catalina!